CVE-2026-9766

Empik for Woocommerce <= 1.5.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Product Meta Update via empik_csv_process_emp_log_classes AJAX Action

Strategic Overview

Status
Patched in 1.5.2
Affected Plugin
Empik for Woocommerce
Affected Version
<= 1.5.1
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-9766
View all Empik for Woocommerce vulnerabilities

At a glance

CVE-2026-9766 is a medium-severity Missing Authorization vulnerability in the Empik for Woocommerce WordPress plugin, affecting versions <= 1.5.1. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.5.2; sites on affected versions should update now. Disclosed September 2026, reported by Benedictus Jovan (aillesiM).

Vulnerability Overview

The Empik for Woocommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.5.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify arbitrary WooCommerce product metadata, including Empik logistic class (_empik_logistic_klass), product state (_empik_product_state, _empik_product_state_all_variants), and Empik export and offer flags on any product in the store.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in Empik for Woocommerce <= 1.5.1 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Empik for Woocommerce the fix is 1.5.2: builds <= 1.5.1 are affected, anything from 1.5.2 onward is not.

Remediation

Update to version 1.5.2, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Empik for Woocommerce 1.5.2 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C