Echo Knowledge Base <= 17.214.0 - Reflected Cross-Site Scripting via 'new_kb_config' Parameter
Strategic Overview
- Status
- Patched in 17.311.0
- Affected Version
<= 17.214.0- CVSS
- 6.1Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- CVE
CVE-2026-101935
At a glance
CVE-2026-101935 is a medium-severity Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in the Echo Knowledge Base WordPress plugin, affecting versions <= 17.214.0. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 17.311.0; sites on affected versions should update now. Disclosed October 2026, reported by crow.
Vulnerability Overview
The Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'new_kb_config' parameter (specifically the article-mobile-break-point-v2 key, among other config keys interpolated into the <style> element) in versions up to, and including, 17.214.0 This is due to insufficient input sanitization and output escaping in EPKB_Frontend_Editor::fe_preview_config() and EPKB_Articles_Setup: on every knowledge base article page view, when the request supplies epkb_fe_reload_mode=on, an attacker-controlled JSON blob is merged over the stored KB configuration and several values are concatenated directly into a stylesheet emitted inside a literal <style> element without escaping (minify_css() does not strip <, > or /). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user (with Editor-level access or above, holding the manage_categories capability, or an Administrator) into performing an action such as clicking on a specially crafted link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Echo Knowledge Base <= 17.214.0 carries this weakness at new_kb_config, and reaching it takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Echo Knowledge Base the fix is 17.311.0: builds <= 17.214.0 are affected, anything from 17.311.0 onward is not.
Remediation
Update to version 17.311.0, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Echo Knowledge Base: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Echo Knowledge Base 17.311.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C