Duplicator Pro < 5.1.0 - Authenticated (Subscriber+) SQL Injection
Strategic Overview
- Status
- Patched in 5.1.0
- Affected Plugin
- Duplicator Pro
- Affected Version
< 5.1.0- CVSS
- 6.5Medium
- Weakness type
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
- CVE
CVE-2026-115262
At a glance
CVE-2026-115262 is a medium-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the Duplicator Pro WordPress plugin, affecting versions < 5.1.0. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 5.1.0; sites on affected versions should update now. Disclosed November 2026, reported by Jakub Herman.
Vulnerability Overview
The Duplicator plugin for WordPress is vulnerable to SQL Injection in all versions up to 5.1.0 (exclusive) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-89: Improper Neutralization of Special Elements used in an SQL Command
Reaching this weakness in Duplicator Pro < 5.1.0 takes an account at Subscriber level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.
A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For Duplicator Pro the fix is 5.1.0: builds < 5.1.0 are affected, anything from 5.1.0 onward is not.
Remediation
Update to version 5.1.0, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Duplicator Pro 5.1.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in Duplicator Pro
- 9.8CVE-2023-6114: Duplicator AND Duplicator Pro < 4.5.14.2
CVE-2023-6114 - 8.8CVE-2026-82814: Duplicator and Duplicator Pro <= 4.6.10
CVE-2026-82814 - 7.5CVE-2020-11738: Duplicator < 1.3.28 Directory Traversal
CVE-2020-11738 - 6.1CVE-2026-112243: Duplicator < 5.1.0 Reflected Cross-Site Scripting
CVE-2026-112243 - 6.1CVE-2023-33309: Duplicator Pro <= 4.5.11 Reflected XSS
CVE-2023-33309 - 5.3CVE-2026-112244: Duplicator < 5.1.0 Full Path Disclosure
CVE-2026-112244
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C