CVE-2026-109236

Customer Email Verification for WooCommerce <= 2.8.2 - Unauthenticated Authentication Bypass via Predictable Email-Verification Token to 'cusomer_email_verify' Parameter

2026-10-27 17:31
Wordfence PRISM

Strategic Overview

Status
Patched in 2.8.3
Affected Version
<= 2.8.2
CVSS
4.8Medium
Weakness type
CWE-287 · Improper Authentication
CVE
CVE-2026-109236
View all Customer Email Verification for WooCommerce vulnerabilities

At a glance

CVE-2026-109236 is a medium-severity Improper Authentication vulnerability in the Customer Email Verification for WooCommerce WordPress plugin, affecting versions <= 2.8.2. It carries a CVSS score of 4.8 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 2.8.3; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.

Vulnerability Overview

The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass via a Predictable Email-Verification Token in all versions up to, and including, 2.8.2. This is due to the `authenticate_user_by_email_link()` function — hooked on the `wp` action and triggered by the `cusomer_email_verify` GET parameter — lacking any capability check or nonce verification, while the `secret_code` it validates is generated as `md5(email . time())` and the `verify_otp_nonce` required to trigger token issuance via the `wp_ajax_nopriv_resend_otp` handler is emitted to every front-end visitor through `wp_localize_script`. This makes it possible for unauthenticated attackers to log in as a newly created, verified WooCommerce customer bound to an arbitrary email address — or to flip an existing account's `customer_email_verified` meta to verified — fully bypassing the plugin's core email-verification control. Exploitation requires the `cev_user_log` table to contain a `password` column, which is absent from the fresh-install schema shipped in version 2.8.2 but is present on sites upgraded from an older version where that column was defined.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.

CWE-287: Improper Authentication

Customer Email Verification for WooCommerce <= 2.8.2 carries this weakness at authenticate_user_by_email_link(), and reaching it takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.

An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Customer Email Verification for WooCommerce the fix is 2.8.3: builds <= 2.8.2 are affected, anything from 2.8.3 onward is not.

Remediation

Update to version 2.8.3, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Customer Email Verification for WooCommerce 2.8.3 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C