Content Egg <= 12.0.0 - Missing Authorization to Authenticated (Author+) Administrator-Authored Post Creation via 'preset_id' Parameter
Strategic Overview
- Status
- Patched in 12.1.0
- Affected Plugin
- Content Egg – Affiliate Product Importer & Price Comparison
- Affected Version
<= 12.0.0- CVSS
- 4.3Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-119087
At a glance
CVE-2026-119087 is a medium-severity Missing Authorization vulnerability in the Content Egg WordPress plugin, affecting versions <= 12.0.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Author level or above. The issue is fixed in version 12.1.0; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.
Vulnerability Overview
The Content Egg – Affiliate Product Importer & Price Comparison plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 12.0.0 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to create posts attributed to another user's account — typically an administrator — by supplying an admin-owned preset_id, causing wp_insert_post to record the administrator as post_author. This includes the ability to create published posts when the attacker already holds publish_posts capability for the preset's post type, resulting in administrator-attributed published content created by a lower-privileged user.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in Content Egg <= 12.0.0 takes an account at Author level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Content Egg the fix is 12.1.0: builds <= 12.0.0 are affected, anything from 12.1.0 onward is not.
Remediation
Update to version 12.1.0, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Content Egg 12.1.0 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Content Egg – Affiliate Product Importer & Price Comparison
- 8.8CVE-2022-25952: Content Egg <= 5.4.0 Cross-Site Request Forgery
CVE-2022-25952 - 8.1CVE-2026-15979: Content Egg <= 11.3.0 Arbitrary File Deletion
CVE-2026-15979 - 6.6CVE-2026-96832: Content Egg PHP Object Injection
CVE-2026-96832 - 6.6CVE-2025-47536: Content Egg <= 7.0.0 PHP Object Injection
CVE-2025-47536 - 6.4CVE-2026-92424: Content Egg <= 11.8.0 Stored Cross-Site Scripting
CVE-2026-92424 - 6.1CVE-2022-0428: Content Egg <= 5.3.0 Reflected Cross-Site Scripting
CVE-2022-0428
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C