CVE-2026-92098

Webheadcoder Multi-Step Forms for Contact Form 7 <= 4.7 - Reflected Cross-Site Scripting via 'l10n_print_after' Parameter

2026-10-27 18:42
Fraudless

Strategic Overview

Status
Patched in 4.7.1
Affected Version
<= 4.7
CVSS
6.1Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE
CVE-2026-92098
View all Webheadcoder Multi-Step Forms for Contact Form 7 vulnerabilities

At a glance

CVE-2026-92098 is a medium-severity Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in the Webheadcoder Multi-Step Forms for Contact Form 7 WordPress plugin, affecting versions <= 4.7. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.7.1; sites on affected versions should update now. Disclosed October 2026, reported by Fraudless.

Vulnerability Overview

The Webheadcoder Multi-Step Forms for Contact Form 7 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'l10n_print_after' parameter in all versions up to, and including, 4.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Successful exploitation requires that the targeted site has at least one Contact Form 7 form configured with a [multistep] form-tag, as the canonicalization introduced in version 4.7 blocks the attack path on non-multistep forms.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Webheadcoder Multi-Step Forms for Contact Form 7 <= 4.7 carries this weakness at l10n_print_after, and reaching it takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Webheadcoder Multi-Step Forms for Contact Form 7 the fix is 4.7.1: builds <= 4.7 are affected, anything from 4.7.1 onward is not.

Remediation

Update to version 4.7.1, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to Webheadcoder Multi-Step Forms for Contact Form 7: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Webheadcoder Multi-Step Forms for Contact Form 7 4.7.1 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C