Clearfy <= 2.4.2 - Unauthenticated Open Redirect
Strategic Overview
- Status
- Patched in 2.4.3
- Affected Version
<= 2.4.2- CVSS
- 4.7Medium
- Weakness type
- CWE-601 · URL Redirection to Untrusted Site
- CVE
CVE-2026-16296
At a glance
CVE-2026-16296 is a medium-severity URL Redirection to Untrusted Site vulnerability in the Clearfy Cache WordPress plugin, affecting versions <= 2.4.2. It carries a CVSS score of 4.7 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.4.3; sites on affected versions should update now. Disclosed August 2026, reported by Revanth Hari Narayana Matte.
Vulnerability Overview
The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Open Redirect in all versions up to, and including, 2.4.2. This is due to insufficient validation on the redirect url supplied. This makes it possible for unauthenticated attackers to redirect users to potentially malicious sites if they can successfully trick them into performing an action.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-601: URL Redirection to Untrusted Site
Reaching this weakness in Clearfy Cache <= 2.4.2 takes no account at all. An open redirect is a page that takes a destination from the request and sends the browser there without checking that the destination belongs to the site.
A link that starts on a trusted domain finishes on an attacker's, which is what makes phishing and consent-screen abuse credible to the person clicking it. For Clearfy Cache the fix is 2.4.3: builds <= 2.4.2 are affected, anything from 2.4.3 onward is not.
Remediation
Update to version 2.4.3, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Clearfy Cache 2.4.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer
- 7.2CVE-2026-3220: Multiple Plugins <= Multiple Versions Stored XSS
CVE-2026-3220 - 6.6CVE-2026-16297: Clearfy <= 2.4.2 PHP Object Injection
CVE-2026-16297 - 6.1Clearfy Cache <= 2.0.4 Reflected Cross-Site Scripting
- 5.3CVE-2024-13338: Webcraftic Clearfy CSRF to Clear Cache
CVE-2024-13338 - 4.3CVE-2026-16295: Clearfy Cache Information Exposure
CVE-2026-16295 - 4.3CVE-2025-13749: Clearfy <= 2.4.0 CSRF to Update Notification Tampering
CVE-2025-13749 - 4.3CVE-2024-13337: Webcraftic Clearfy CSRF to Plugin Settings Update
CVE-2024-13337 - 4.3CVE-2024-43260: Clearfy Cache <= 2.2.4 Missing Authorization
CVE-2024-43260
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C