Classified Listing – AI-Powered Classified ads & Business Directory <= 6.1.5 - Authenticated (Subscriber+) Arbitrary PHP Code Execution
Strategic Overview
- Status
- Patched in 6.2.0
- Affected Version
<= 6.1.5- CVSS
- 8.8High
- Weakness type
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
- CVE
CVE-2026-111828
At a glance
CVE-2026-111828 is a high-severity Improper Control of Generation of Code ('Code Injection') vulnerability in the Classified Listing WordPress plugin, affecting versions <= 6.1.5. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 6.2.0; sites on affected versions should update now. Disclosed October 2026, reported by changsheng.
Vulnerability Overview
The Classified Listing – AI-Powered Classified ads & Business Directory plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 6.1.5. This is due to an inverted condition in the radio/select field type validation (`!is_array` instead of `is_array`) that caused the allowlist check to be skipped for every well-formed options array, and a `wp_kses_post()` call whose return value was discarded, together allowing arbitrary values to be stored in plugin settings that are later written to static PHP configuration files. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary PHP code into plugin-generated static files, allowing execution of malicious code on the server. The attacker must have access to an AJAX settings endpoint lacking a sufficient capability check; a missing authentication guard (one of the two auth_check additions in this release) allowed Subscriber-level users to reach the settings save handler.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-94: Improper Control of Generation of Code ('Code Injection')
Classified Listing <= 6.1.5 carries this weakness at wp_kses_post(), and reaching it takes an account at Subscriber level or above. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Classified Listing the fix is 6.2.0: builds <= 6.1.5 are affected, anything from 6.2.0 onward is not.
Remediation
Update to version 6.2.0, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Classified Listing 6.2.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in Classified Listing – AI-Powered Classified ads & Business Directory
- 8.8CVE-2025-52715: Classified Listing <= 4.2.0 Local File Inclusion
CVE-2025-52715 - 8.8CVE-2024-11194: Classified Listing Limited Arbitrary Option Update
CVE-2024-11194 - 8.8CVE-2024-52386: Classified Listing <= 3.1.16 Local File Inclusion
CVE-2024-52386 - 8.8CVE-2024-1315: Classified Listing <= 3.0.4 CSRF to Account Takeover
CVE-2024-1315 - 7.2CVE-2026-96351: Classified Listing Stored XSS
CVE-2026-96351 - 7.2CVE-2026-57344: Classified Listing Stored XSS
CVE-2026-57344 - 7.2CVE-2026-42658: Classified Listing Stored XSS
CVE-2026-42658 - 6.5CVE-2024-1352: Classified Listing Missing Authorization
CVE-2024-1352
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C