CVE-2026-62057

CF7 Mate – Contact Form 7 Styler, Multi-Step Forms & Conditional Logic <= 4.1.0 - Unauthenticated Arbitrary Shortcode Execution

2026-10-30 00:00
braintx

Strategic Overview

Status
Patched in 4.1.1
Affected Version
<= 4.1.0
CVSS
6.5Medium
Weakness type
CWE-94 · Improper Control of Generation of Code
CVE
CVE-2026-62057
View all CF7 Mate – Contact Form 7 Styler, Multi-Step Forms & Conditional Logic vulnerabilities

At a glance

CVE-2026-62057 is a medium-severity Improper Control of Generation of Code vulnerability in the CF7 Mate WordPress plugin, affecting versions <= 4.1.0. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.1.1; sites on affected versions should update now. Disclosed October 2026, reported by braintx.

Vulnerability Overview

The CF7 Mate – Contact Form 7 Styler, Multi-Step Forms & Conditional Logic plugin for WordPress is vulnerable to Cross-Site Scripting in all versions up to, and including, 4.1.0. This is due to missing sanitization on the formId module attribute before its value is passed to do_shortcode, allowing non-alphanumeric characters to influence the rendered shortcode output. This makes it possible for unauthenticated attackers to inject arbitrary content into pages via an unsanitized form ID attribute that is interpolated into a shortcode executed on page render.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-94: Improper Control of Generation of Code

Reaching this weakness in CF7 Mate <= 4.1.0 takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.

The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For CF7 Mate the fix is 4.1.1: builds <= 4.1.0 are affected, anything from 4.1.1 onward is not.

Remediation

Update to version 4.1.1, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: CF7 Mate 4.1.1 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Login Security

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C