CVE-2024-8246

Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC) <= 2.8.11 - Authenticated (Contributor+) Privilege Escalation

2024-09-13 00:00
wesley (wcraft)

Strategic Overview

Status
Patched in 2.8.12
Affected Plugin
BuddyForms
Affected Version
<= 2.8.11
CVSS
8.8High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2024-8246
View all BuddyForms vulnerabilities

At a glance

CVE-2024-8246 is a high-severity Improper Privilege Management vulnerability in the BuddyForms WordPress plugin, affecting versions <= 2.8.11. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 2.8.12; sites on affected versions should update now. Disclosed September 2024, reported by wesley (wcraft).

Vulnerability Overview

The Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC) plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 2.8.11. This is due to plugin not properly restricting what users have access to set the default role on registration forms. This makes it possible for authenticated attackers, with contributor-level access and above, to create a registration form with a custom role that allows them to register as administrators.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

Reaching this weakness in BuddyForms <= 2.8.11 takes an account at Contributor level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For BuddyForms the fix is 2.8.12: builds <= 2.8.11 are affected, anything from 2.8.12 onward is not.

Remediation

Update to version 2.8.12, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: BuddyForms 2.8.12 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C