CVE-2026-118082

BuddyBoss Platform <= 3.5.0 - Authenticated (Subscriber+) Privilege Escalation

2026-10-28 00:00
Hung Bach Ngoc

Strategic Overview

Status
Patched in 3.6.1
Affected Plugin
BuddyBoss Platform
Affected Version
<= 3.5.0
CVSS
8.8High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-118082
View all BuddyBoss Platform vulnerabilities

At a glance

CVE-2026-118082 is a high-severity Improper Privilege Management vulnerability in the BuddyBoss Platform WordPress plugin, affecting versions <= 3.5.0. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.6.1; sites on affected versions should update now. Disclosed October 2026, reported by Hung Bach Ngoc.

Vulnerability Overview

The BuddyBoss Platform plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.5.0. This is due to insufficient restriction on the capabilities a user may grant themselves. This makes it possible for authenticated attackers, with subscriber-level access and above, to elevate their privileges beyond those intended for their role.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

Reaching this weakness in BuddyBoss Platform <= 3.5.0 takes an account at Subscriber level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For BuddyBoss Platform the fix is 3.6.1: builds <= 3.5.0 are affected, anything from 3.6.1 onward is not.

Remediation

Update to version 3.6.1, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: BuddyBoss Platform 3.6.1 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C