CVE-2026-89093

Better Messages <= 2.15.33 - Unauthenticated Information Exposure Spoofing via 'X-Real-IP' Header via /guests/register

Strategic Overview

Status
Patched in 3.0.0
Affected Version
<= 2.15.33
CVSS
5.3Medium
Weakness type
CWE-287 · Improper Authentication
CVE
CVE-2026-89093
View all Better Messages – Chat Rooms, Group Chat, Private Messages & AI Chat Bots vulnerabilities

At a glance

CVE-2026-89093 is a medium-severity Improper Authentication vulnerability in the Better Messages WordPress plugin, affecting versions <= 2.15.33. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.0.0; sites on affected versions should update now. Disclosed September 2026, reported by Jonah Burgess (CryptoCat).

Vulnerability Overview

The Better Messages – Chat Rooms, Group Chat, Private Messages & AI Chat Bots plugin for WordPress is vulnerable to Information Exposure by Spoofing in all versions up to, and including, 2.15.33. This is due to the `is_ai_bot_user()` function identifying privileged internal AI bot accounts by performing a prefix check for `'ai-chat-bot-'` against a guest record's stored IP address, which is populated verbatim from the client-controlled `X-Real-IP` request header during unauthenticated guest registration. This makes it possible for unauthenticated attackers to register a guest identity that the plugin treats as its own internal AI bot, bypassing the per-room role allowlist, draft-status check, and join filters — which are all short-circuited by the bot check in `user_can_join()` and `user_can_read()` — to join administrator-restricted chat rooms, post messages into them, and read the private message history of other users.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-287: Improper Authentication

Better Messages <= 2.15.33 carries this weakness at ai-chat-bot-, and reaching it takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.

An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Better Messages the fix is 3.0.0: builds <= 2.15.33 are affected, anything from 3.0.0 onward is not.

Remediation

Update to version 3.0.0, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Better Messages 3.0.0 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C