CVE-2023-49751

Block for Font Awesome <= 1.4.0 - Cross-Site Request Forgery

2023-12-04 00:00
Nguyen Xuan Chien

Strategic Overview

Status
Patched in 1.4.1
Affected Version
<= 1.4.0
CVSS
4.3Medium
Weakness type
CWE-352 · Cross-Site Request Forgery (CSRF)
CVE
CVE-2023-49751
View all Block for Font Awesome Icons – Searchable Icon Picker, SVG, FA 7 vulnerabilities

At a glance

CVE-2023-49751 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the Block for Font Awesome Icons WordPress plugin, affecting versions <= 1.4.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.4.1; sites on affected versions should update now. Disclosed December 2023, reported by Nguyen Xuan Chien.

Vulnerability Overview

The Block for Font Awesome plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.4.0. This is due to missing or incorrect nonce validation on the getbutterfly_fa_build_admin_page() function. This makes it possible for unauthenticated attackers to update the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-352: Cross-Site Request Forgery (CSRF)

Block for Font Awesome Icons <= 1.4.0 carries this weakness at getbutterfly_fa_build_admin_page(), and reaching it takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Block for Font Awesome Icons the fix is 1.4.1: builds <= 1.4.0 are affected, anything from 1.4.1 onward is not.

Remediation

Update to version 1.4.1, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to Block for Font Awesome Icons: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Block for Font Awesome Icons 1.4.1 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Other vulnerabilities in Block for Font Awesome Icons – Searchable Icon Picker, SVG, FA 7

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C