BigBuy Dropshipping Connector for WooCommerce <= 2.0.5 - Unauthenticated IP Spoofing to phpinfo() Exposure
Strategic Overview
- Status
- Patched in 2.1.0
- Affected Plugin
- BigBuy Dropshipping Connector for WooCommerce
- Affected Version
<= 2.0.5- CVSS
- 5.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2025-12039
At a glance
CVE-2025-12039 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the BigBuy Dropshipping Connector for WooCommerce WordPress plugin, affecting versions <= 2.0.5. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.1.0; sites on affected versions should update now. Disclosed November 2025, reported by Jarno Vos (jarnovos).
Vulnerability Overview
The BigBuy Dropshipping Connector for WooCommerce plugin for WordPress is vulnerable to IP Address Spoofing in all versions up to, and including, 2.0.5 due to insufficient IP address validation and use of user-supplied HTTP headers as a primary method for IP retrieval. This makes it possible for unauthenticated attackers to retrieve the output of phpinfo().
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
BigBuy Dropshipping Connector for WooCommerce <= 2.0.5 carries this weakness at phpinfo(), and reaching it takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For BigBuy Dropshipping Connector for WooCommerce the fix is 2.1.0: builds <= 2.0.5 are affected, anything from 2.1.0 onward is not.
Remediation
Update to version 2.1.0, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: BigBuy Dropshipping Connector for WooCommerce 2.1.0 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in BigBuy Dropshipping Connector for WooCommerce
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C