CVE-2026-76780

BeyondSEO <= 1.3.6 - Missing Authorization to Authenticated (Contributor+) Limited Privilege Escalation

2026-10-27 18:12
Wordfence PRISM

Strategic Overview

Status
Patched in 1.3.7
Affected Version
<= 1.3.6
CVSS
6.3Medium
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-76780
View all BeyondSEO – AI SEO to Improve Rankings, Listings & Online Visibility vulnerabilities

At a glance

CVE-2026-76780 is a medium-severity Improper Privilege Management vulnerability in the BeyondSEO WordPress plugin, affecting versions <= 1.3.6. It carries a CVSS score of 6.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 1.3.7; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.

Vulnerability Overview

The Beyondseo plugin for WordPress is vulnerable to unauthorized access in versions up to, and including, 1.3.6. This is due to the plugin permanently granting the 'rankingcoach_write_redirectManager' (and sibling rankingcoach_write_* module capabilities) to the Contributor role via BaseModule::defineCapabilities(), whose default role list includes 'contributor', combined with the module's REST endpoints (registered through BaseSubmoduleApi::registerRouteCreate/registerRouteEdit/registerRouteDelete) authorizing state-changing requests solely through checkPermissionsPost(), which only calls current_user_can('rankingcoach_write_<module>') and performs no admin capability, ownership, or additional nonce check inside the callback. This makes it possible for authenticated attackers, with Contributor-level access and above, to elevate their privileges to effectively that of an Administrator with respect to site-wide redirect management — creating, updating, or deleting 301/302 redirects that RedirectManagerHooks::handleRedirects() executes for every frontend visitor on template_redirect, allowing hijacking of arbitrary paths (including /checkout, /wp-login.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-269: Improper Privilege Management

BeyondSEO <= 1.3.6 carries this weakness at rankingcoach_write_redirectManager, and reaching it takes an account at Contributor level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For BeyondSEO the fix is 1.3.7: builds <= 1.3.6 are affected, anything from 1.3.7 onward is not.

Remediation

Update to version 1.3.7, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: BeyondSEO 1.3.7 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C