JetBackup – Backup, Restore & Migrate <= 3.1.24.9 - Authenticated (Admin+) Arbitrary File Write
Strategic Overview
- Status
- Patched in 3.1.24.10
- Affected Plugin
- JetBackup – Backup, Restore & Migrate
- Affected Version
<= 3.1.24.9- CVSS
- 4.7Medium
- Weakness type
- CWE-59 · Improper Link Resolution Before File Access
- CVE
CVE-2026-104068
At a glance
CVE-2026-104068 is a medium-severity Improper Link Resolution Before File Access vulnerability in the JetBackup WordPress plugin, affecting versions <= 3.1.24.9. It carries a CVSS score of 4.7 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Admin level or above. The issue is fixed in version 3.1.24.10; sites on affected versions should update now. Disclosed October 2026, reported by Sarvar Eshboyev.
Vulnerability Overview
The JetBackup – Backup, Restore & Migrate plugin for WordPress is vulnerable to Arbitrary File Write in all versions up to, and including, 3.1.24.9. This is due to missing destination-containment validation on symlink targets during archive extraction in the SYMTYPE case of the extract method, allowing symlinks pointing outside the extraction directory to be created without restriction. This makes it possible for authenticated attackers, with admin-level access and above, to write attacker-controlled file contents to arbitrary locations on the server by including a maliciously crafted symbolic link in a backup archive, potentially leading to remote code execution. The attacker must have administrator-level access to the WordPress installation and the ability to import or restore a crafted backup archive.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-59: Improper Link Resolution Before File Access
The product attempts to access a file based on the filename, but it does not properly prevent that filename from identifying a link or shortcut that resolves to an unintended resource.
Remediation
Update to version 3.1.24.10, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: JetBackup 3.1.24.10 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in JetBackup – Backup, Restore & Migrate
- 9.8CVE-2023-7165: JetBackup <= 2.0.9.7 Sensitive Information Exposure
CVE-2023-7165 - 8.8CVE-2020-36669: JetBackup CSRF to Arbitrary File Upload
CVE-2020-36669 - 8.8WordPress Backup and Migrate Plugin Arbitrary File Upload
- 7.2CVE-2021-24155: Backup Guard <= 1.5.9 Arbitrary File Upload
CVE-2021-24155 - 6.3CVE-2026-19453: JetBackup Privilege Escalation
CVE-2026-19453 - 6.1CVE-2017-10837: BackupGuard <= 1.1.46 Reflected Cross-Site Scripting
CVE-2017-10837 - 6.1CVE-2017-18488: Backup Guard <= 1.1.46 Cross-Site Scripting
CVE-2017-18488 - 5.5CVE-2022-34148: Backup Guard <= 1.6.9 Stored Cross-Site Scripting
CVE-2022-34148
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C