AutomatorWP <= 6.0.4 - Unauthenticated Privilege Escalation to Insufficient Role Validation in Anonymous Automation 'Role' Option
Strategic Overview
- Status
- Patched in 6.0.5
- Affected Plugin
- AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI
- Affected Version
<= 6.0.4- CVSS
- 7.5High
- Weakness type
- CWE-269 · Improper Privilege Management
- CVE
CVE-2026-104768
At a glance
CVE-2026-104768 is a high-severity Improper Privilege Management vulnerability in the AutomatorWP WordPress plugin, affecting versions <= 6.0.4. It carries a CVSS score of 7.5 (reachable over the network; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 6.0.5; sites on affected versions should update now. Disclosed November 2026, reported by John Ryan Albon.
Vulnerability Overview
The AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.0.4. This is due to missing privilege-ceiling validation in the `create_user()` function within the anonymous-user action (and equally in the Create User and Add/Change Role WordPress-integration actions), which verify only that the submitted role exists via `automatorwp_get_editable_roles()` without confirming the role falls at or below the acting context's privilege level — allowing attacker-controlled trigger tag data (e.g., a `{comment_author}` tag bound to the Role option) to supply any role, including `administrator`, unchallenged. This makes it possible for unauthenticated attackers to create a new administrator-role account tied to an attacker-controlled email address, receiving the generated password via WordPress's new-user notification email and thereby gaining full administrative access to the site. Exploitation requires the site to have an anonymous automation configured with the Role option bound to a dynamic trigger tag such as `{comment_author}`, and is triggered when a site administrator performs the routine action of approving a comment — an action that provides no in-UI indication that it will mint a new privileged account from the comment author field.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-269: Improper Privilege Management
AutomatorWP <= 6.0.4 carries this weakness at create_user(), and reaching it takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.
It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For AutomatorWP the fix is 6.0.5: builds <= 6.0.4 are affected, anything from 6.0.5 onward is not.
Remediation
Update to version 6.0.5, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: AutomatorWP 6.0.5 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI
- 9.6CVE-2024-12626: AutomatorWP <= 5.0.9 Reflected Cross-Site Scripting
CVE-2024-12626 - 8.0CVE-2025-9539: AutomatorWP Authenticated (Subscriber+) RCE
CVE-2025-9539 - 7.2CVE-2026-42775: AutomatorWP Stored XSS
CVE-2026-42775 - 7.2CVE-2026-42650: AutomatorWP Stored XSS
CVE-2026-42650 - 7.2CVE-2025-5487: AutomatorWP <= 5.2.5 SQL Injection
CVE-2025-5487 - 5.4CVE-2025-9542: AutomatorWP <= 5.3.7 Multiple Functions
CVE-2025-9542 - 4.9CVE-2025-68561: AutomatorWP <= 5.2.4 SQL Injection
CVE-2025-68561 - 4.9CVE-2025-48280: AutomatorWP <= 5.2.1.3 SQL Injection
CVE-2025-48280
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C