Strategic Overview
- Status
- Patched in 1.1.8
- Affected Plugin
- asVereinbase – Club & Member Management for WP
- Affected Version
<= 1.1.7- CVSS
- 5.3Medium
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-110956
At a glance
CVE-2026-110956 is a medium-severity Improper Authentication vulnerability in the asVereinbase WordPress plugin, affecting versions <= 1.1.7. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.1.8; sites on affected versions should update now. Disclosed October 2026.
Vulnerability Overview
The asVereinbase plugin for WordPress is vulnerable to Two-Factor Authentication Bypass in all versions up to, and including, 1.1.7. This is due to the authentication logic treating an empty stored credential value as a successful match against any supplied input, allowing the check to pass without a valid password or second factor. This makes it possible for unauthenticated attackers to log in as any registered user, including administrators, by exploiting the flawed credential check.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-287: Improper Authentication
Reaching this weakness in asVereinbase <= 1.1.7 takes a caller who can reach the endpoint. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For asVereinbase the fix is 1.1.8: builds <= 1.1.7 are affected, anything from 1.1.8 onward is not.
Remediation
Update to version 1.1.8, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: asVereinbase 1.1.8 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C