CVE-2026-13770

AppMySite <= 3.15.3 - Authenticated (Subscriber+) Stored Cross-Site Scripting via save_ams_license_key AJAX Handler

2026-09-18 18:48
Mitchell

Strategic Overview

Status
Patched in 3.15.4
Affected Version
<= 3.15.3
CVSS
6.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-13770
View all AppMySite – WordPress & WooCommerce Mobile App Builder (No-Code Android & iOS App Maker) vulnerabilities

At a glance

CVE-2026-13770 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the AppMySite WordPress plugin, affecting versions <= 3.15.3. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.15.4; sites on affected versions should update now. Disclosed September 2026, reported by Mitchell.

Vulnerability Overview

The AppMySite – WordPress & WooCommerce Mobile App Builder (No-Code Android & iOS App Maker) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via save_ams_license_key AJAX Handler in all versions up to, and including, 3.15.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The save_ams_license_key AJAX handler performs no capability check and no nonce verification, meaning any authenticated user with Subscriber-level access or above can invoke it to store the malicious payload.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Reaching this weakness in AppMySite <= 3.15.3 takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For AppMySite the fix is 3.15.4: builds <= 3.15.3 are affected, anything from 3.15.4 onward is not.

Remediation

Update to version 3.15.4, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: AppMySite 3.15.4 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C