CVE-2026-102564

Dynific Addons for Elementor (formerly Anywhere Elementor) <= 1.3.0 - Unauthenticated Arbitrary Shortcode Execution via Comment Content via do_shortcode() over rendered template buffer

2026-11-06 22:44
Kuba

Strategic Overview

Status
Patched in 1.3.1
Affected Version
<= 1.3.0
CVSS
6.5Medium
Weakness type
CWE-94 · Improper Control of Generation of Code
CVE
CVE-2026-102564
View all Dynific Addons for Elementor (formerly Anywhere Elementor) vulnerabilities

At a glance

CVE-2026-102564 is a medium-severity Improper Control of Generation of Code vulnerability in the Dynific Addons for Elementor (formerly Anywhere Elementor) WordPress plugin, affecting versions <= 1.3.0. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.3.1; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.

Vulnerability Overview

The The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.3.0 This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires the target site to have a public post rendered through an AE template that includes the AE Post Comments widget, and for the attacker's comment to be visible on that page — a barrier removed once the attacker has a previously approved comment or when comment moderation is relaxed.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-94: Improper Control of Generation of Code

Reaching this weakness in Dynific Addons for Elementor (formerly Anywhere Elementor) <= 1.3.0 takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.

The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Dynific Addons for Elementor (formerly Anywhere Elementor) the fix is 1.3.1: builds <= 1.3.0 are affected, anything from 1.3.1 onward is not.

Remediation

Update to version 1.3.1, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Dynific Addons for Elementor (formerly Anywhere Elementor) 1.3.1 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Login Security

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C