CVE-2026-104992

Booking for Appointments and Events Calendar <= 9.9.1 - Missing Authorization to Authenticated (Custom+) Sensitive Information Disclosure via '/report/event/bookings' Endpoint

2026-11-06 21:20
Adarter

Strategic Overview

Status
Patched in 9.9.2
Affected Version
9.0 – 9.9.1
CVSS
6.5Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-104992
View all Booking for Appointments and Events Calendar – Amelia vulnerabilities

At a glance

CVE-2026-104992 is a medium-severity Missing Authorization vulnerability in the Booking for Appointments and Events Calendar WordPress plugin, affecting versions 9.0 – 9.9.1. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Custom level or above. The issue is fixed in version 9.9.2; sites on affected versions should update now. Disclosed November 2026, reported by Adarter.

Vulnerability Overview

The Booking for Appointments and Events Calendar – Amelia plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 9.9.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with custom-level access and above, to export a full CSV of booking records for any event on the site — including attendee names, email addresses, phone numbers, booking status, number of persons, price, payment status, payment amount, and coupon codes — regardless of whether they own or participate in those events.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-862: Missing Authorization

Reaching this weakness in Booking for Appointments and Events Calendar 9.0 – 9.9.1 takes an account at Custom level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Booking for Appointments and Events Calendar the fix is 9.9.2: builds 9.0 – 9.9.1 are affected, anything from 9.9.2 onward is not.

Remediation

Update to version 9.9.2, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Booking for Appointments and Events Calendar 9.9.2 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C