AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini <= 3.8.8 - Cross-Site Request Forgery
Strategic Overview
- Status
- Patched in 3.8.9
- Affected Version
<= 3.8.8- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery
- CVE
CVE-2026-65566
At a glance
CVE-2026-65566 is a medium-severity Cross-Site Request Forgery vulnerability in the AI Engine WordPress plugin, affecting versions <= 3.8.8. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 3.8.9; sites on affected versions should update now. Disclosed October 2026, reported by AndrewN.
Vulnerability Overview
The AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.8.8. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery
Reaching this weakness in AI Engine <= 3.8.8 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For AI Engine the fix is 3.8.9: builds <= 3.8.8 are affected, anything from 3.8.9 onward is not.
Remediation
Update to version 3.8.9, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to AI Engine: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: AI Engine 3.8.9 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini
- 9.8CVE-2025-11749: AI Engine Info Exposure to Privilege Escalation
CVE-2025-11749 - 9.8CVE-2023-51409: AI Engine: ChatGPT Chatbot Arbitrary File Upload
CVE-2023-51409 - 9.1CVE-2024-34440: AI Engine: ChatGPT Chatbot Arbitrary File Upload
CVE-2024-34440 - 8.8CVE-2026-8719: AI Engine 3.4.9 Privilege Escalation
CVE-2026-8719 - 8.8CVE-2025-7847: AI Engine 2.9.3 - 2.9.4 Arbitrary File Upload
CVE-2025-7847 - 8.8CVE-2025-5071: AI Engine 2.8.0 - 2.8.3 Insufficient Authorization
CVE-2025-5071 - 8.0CVE-2025-6238: AI Engine 2.8.4 Insecure OAuth Implementation
CVE-2025-6238 - 7.5CVE-2026-110732: AI Engine Administrator Account Takeover
CVE-2026-110732
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C