AI Engine <= 3.8.4 - Authenticated (Subscriber+) Limited Media File Deletion via 'metadata' Parameter
Strategic Overview
- Status
- Patched in 3.8.5
- Affected Version
<= 3.8.4- CVSS
- 4.2Medium
- Weakness type
- CWE-22 · Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
- CVE
CVE-2026-107745
At a glance
CVE-2026-107745 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in the AI Engine WordPress plugin, affecting versions <= 3.8.4. It carries a CVSS score of 4.2 (reachable over the network). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.8.5; sites on affected versions should update now. Disclosed October 2026, reported by Sawyer.
Vulnerability Overview
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to limited media file deletion due to insufficient file path validation in the upload_file function in all versions up to, and including, 3.8.4 This makes it possible for authenticated attackers, with subscriber-level access and above, to delete arbitrary media files on the server. This requires the administrator to have enabled the Public API option, and exploitation depends on the hourly cleanup_files task running after the malicious upload.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user.
CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Reaching this weakness in AI Engine <= 3.8.4 takes an account at Subscriber level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.
Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For AI Engine the fix is 3.8.5: builds <= 3.8.4 are affected, anything from 3.8.5 onward is not.
Remediation
Update to version 3.8.5, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: AI Engine 3.8.5 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini
- 9.8CVE-2025-11749: AI Engine Info Exposure to Privilege Escalation
CVE-2025-11749 - 9.8CVE-2023-51409: AI Engine: ChatGPT Chatbot Arbitrary File Upload
CVE-2023-51409 - 9.1CVE-2024-34440: AI Engine: ChatGPT Chatbot Arbitrary File Upload
CVE-2024-34440 - 8.8CVE-2026-15988: AI Engine <= 3.6.5 CSRF to Privilege Escalation
CVE-2026-15988 - 8.8CVE-2026-8719: AI Engine 3.4.9 Privilege Escalation
CVE-2026-8719 - 8.8CVE-2025-7847: AI Engine 2.9.3 - 2.9.4 Arbitrary File Upload
CVE-2025-7847 - 8.8CVE-2025-5071: AI Engine 2.8.0 - 2.8.3 Insufficient Authorization
CVE-2025-5071 - 8.0CVE-2025-6238: AI Engine 2.8.4 Insecure OAuth Implementation
CVE-2025-6238
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C