Advanced Contact form 7 DB <= 2.1.1 - Missing Authorization to Authenticated (Contributor+) Information Disclosure via 'acf7db' Shortcode
Strategic Overview
- Status
- Patched in 2.1.2
- Affected Plugin
- Advanced Contact form 7 DB
- Affected Version
<= 2.1.1- CVSS
- 6.5Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-6831
At a glance
CVE-2026-6831 is a medium-severity Missing Authorization vulnerability in the Advanced Contact form 7 DB WordPress plugin, affecting versions <= 2.1.1. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 2.1.2; sites on affected versions should update now. Disclosed September 2026, reported by Quốc Huy (jtwings).
Vulnerability Overview
The Advanced Contact form 7 DB plugin for WordPress is vulnerable to missing authorization in all versions up to, and including, 2.0.9. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with Contributor-level access and above, to read all Contact Form 7 submission data via the 'acf7db' shortcode.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-862: Missing Authorization
Advanced Contact form 7 DB <= 2.1.1 carries this weakness at acf7db, and reaching it takes an account at Contributor level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Advanced Contact form 7 DB the fix is 2.1.2: builds <= 2.1.1 are affected, anything from 2.1.2 onward is not.
Remediation
Update to version 2.1.2, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Advanced Contact form 7 DB 2.1.2 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
- 5.3CVE-2024-4319: Advanced… Unauthenticated Information Disclosure
CVE-2024-4319 - 4.3CVE-2026-18594: Advanced Contact form 7 DB Authenticated (Custom+)
CVE-2026-18594 - 4.3CVE-2026-57669: Advanced Contact form 7 DB Missing Authorization
CVE-2026-57669 - 4.3CVE-2026-0814: Advanced CF7 DB Authenticated (Subscriber+) Form
CVE-2026-0814
Other vulnerabilities in Advanced Contact form 7 DB
- 9.8CVE-2019-13571: Advanced Contact Form 7 DB <= 1.6.2 SQL Injection
CVE-2019-13571 - 8.8CVE-2021-24905: Advanced Contact form 7 DB Arbitrary File Deletion
CVE-2021-24905 - 8.5Advanced Contact form 7 DB <= 1.6.0 SQL Injection
- 7.5CVE-2024-45293: PHPSpreadsheet Library < 2.3.0 XXE Injection
CVE-2024-45293 - 6.1CVE-2022-29408: Advanced Contact form 7 DB <= 1.8.7 Stored XSS
CVE-2022-29408 - 5.4CVE-2026-0811: Advanced CF7 DB <= 2.0.9 CSRF to Form Entry Deletion
CVE-2026-0811 - 5.3CVE-2024-3723: Advanced Contact form 7 DB <= 2.0.2 Info Exposure
CVE-2024-3723 - 3.7CVE-2014-2054: Advanced Contact… & Import any XML, CSV or Excel File
CVE-2014-2054
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C