AMP for WP <= 1.1.18 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via Author Biographical Info
Strategic Overview
- Status
- Patched in 1.1.19
- Affected Plugin
- AMP for WP – Accelerated Mobile Pages
- Affected Version
<= 1.1.18- CVSS
- 5.4Medium
- Weakness type
- CWE-94 · Improper Control of Generation of Code
- CVE
CVE-2026-103908
At a glance
CVE-2026-103908 is a medium-severity Improper Control of Generation of Code vulnerability in the AMP for WP WordPress plugin, affecting versions <= 1.1.18. It carries a CVSS score of 5.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.1.19; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.
Vulnerability Overview
The The AMP for WP – Accelerated Mobile Pages plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.1.18. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with custom-level access and above, to execute arbitrary shortcodes. The vulnerable output block is gated by the 'ampforwp-cat-description' setting, which is enabled by default, meaning the vast majority of installations are affected without any additional configuration change.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-94: Improper Control of Generation of Code
AMP for WP <= 1.1.18 carries this weakness at ampforwp-cat-description, and reaching it takes an account at Subscriber level or above. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.
The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For AMP for WP the fix is 1.1.19: builds <= 1.1.18 are affected, anything from 1.1.19 onward is not.
Remediation
Update to version 1.1.19, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: AMP for WP 1.1.19 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Alerts
External References
Related records
Other vulnerabilities in AMP for WP – Accelerated Mobile Pages
- 8.8CVE-2024-9598: AMP for WP CSRF to Privilege Escalation
CVE-2024-9598 - 7.5CVE-2026-6101: AMP for WP <= 1.1.12 Arbitrary File Write
CVE-2026-6101 - 7.2CVE-2026-97019: AMP for WP <= 1.1.17 Stored Cross-Site Scripting
CVE-2026-97019 - 7.2CVE-2026-83591: AMP for WP <= 1.1.16 Stored Cross-Site Scripting
CVE-2026-83591 - 6.5CVE-2024-1043: AMP for WP <= 1.0.93.1 Arbitrary Post Deletion
CVE-2024-1043 - 6.4CVE-2026-0627: AMP for WP <= 1.1.10 Stored Cross-Site Scripting
CVE-2026-0627 - 6.4CVE-2024-6896: AMP for WP – Accelerated Mobile Pages Stored XSS
CVE-2024-6896 - 6.4CVE-2023-6782: AMP for WP – Accelerated Mobile Pages <= 1.0.92 XSS
CVE-2023-6782
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C