Academy LMS <= 3.3.4 - Authenticated (Academy Instructor+) Insecure Direct Object Reference
Strategic Overview
- Status
- Patched in 3.3.5
- Affected Version
<= 3.3.4- CVSS
- 4.3Medium
- Weakness type
- CWE-639 · Authorization Bypass Through User-Controlled Key
- CVE
CVE-2025-59562
At a glance
CVE-2025-59562 is a medium-severity Authorization Bypass Through User-Controlled Key vulnerability in the Academy LMS WordPress plugin, affecting versions <= 3.3.4. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Academy Instructor level or above. The issue is fixed in version 3.3.5; sites on affected versions should update now. Disclosed September 2025, reported by n0_arafat_n0.
Vulnerability Overview
The Academy LMS – WordPress LMS Plugin for Complete eLearning Solution plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.3.4 due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Academy Instructor-level access and above, to perform an unauthorized action.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-639: Authorization Bypass Through User-Controlled Key
Reaching this weakness in Academy LMS <= 3.3.4 takes an account at Academy Instructor level or above. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.
Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For Academy LMS the fix is 3.3.5: builds <= 3.3.4 are affected, anything from 3.3.5 onward is not.
Remediation
Update to version 3.3.5, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Academy LMS 3.3.5 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
- 9.8CVE-2025-15521: Academy LMS Privilege Escalation
CVE-2025-15521 - 5.3CVE-2026-5348: Academy LMS <= 3.8.1 IDOR to Private Topic Disclosure
CVE-2026-5348 - 4.3CVE-2026-104050: Academy LMS <= 3.0.0 Insecure Direct Object Reference
CVE-2026-104050 - 4.3CVE-2026-104049: Academy LMS <= 3.0.0 Insecure Direct Object Reference
CVE-2026-104049
Other vulnerabilities in Academy LMS – AI Course Builder, Quizzes, Certificates & eLearning
- 8.8CVE-2024-1505: Academy LMS Privilege Escalation
CVE-2024-1505 - 8.3CVE-2024-37234: Academy LMS <= 2.0.10 Open Redirect
CVE-2024-37234 - 7.2CVE-2025-12099: Academy LMS PHP Object Injection
CVE-2025-12099 - 6.5CVE-2026-104915: Academy LMS Authenticated (Custom+) Arbitrary
CVE-2026-104915 - 6.4CVE-2025-68527: Academy LMS <= 3.4.0 Stored Cross-Site Scripting
CVE-2025-68527 - 5.4CVE-2026-104022: Academy LMS Privilege Escalation
CVE-2026-104022 - 5.4CVE-2024-32714: Academy LMS <= 1.9.16 Missing Authorization
CVE-2024-32714 - 5.3CVE-2024-35171: Academy LMS <= 1.9.25 Sensitive Information Exposure
CVE-2024-35171
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C