aBlocks – WordPress Gutenberg Blocks <= 2.4.0 - Missing Authorization to Authenticated (Subscriber+) Settings Modification
Strategic Overview
- Status
- Patched in 2.5.0
- Affected Plugin
- aBlocks – Gutenberg Blocks, User Dashboard Builder, Popup Builder, Form Builder & Animation Builder
- Affected Version
<= 2.4.0- CVSS
- 5.4Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2025-12449
At a glance
CVE-2025-12449 is a medium-severity Missing Authorization vulnerability in the aBlocks WordPress plugin, affecting versions <= 2.4.0. It carries a CVSS score of 5.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.5.0; sites on affected versions should update now. Disclosed January 2026, reported by mahdi salhi (CaptinSharky01).
Vulnerability Overview
The aBlocks – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to unauthorized modification of data and disclosure of sensitive information due to missing capability checks on multiple AJAX actions in all versions up to, and including, 2.4.0. This makes it possible for authenticated attackers, with subscriber level access and above, to read plugin settings including block visibility, maintenance mode configuration, and third-party email marketing API keys, as well as read sensitive configuration data including API keys for email marketing services.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-862: Missing Authorization
Reaching this weakness in aBlocks <= 2.4.0 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For aBlocks the fix is 2.5.0: builds <= 2.4.0 are affected, anything from 2.5.0 onward is not.
Remediation
Update to version 2.5.0, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: aBlocks 2.5.0 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in aBlocks – Gutenberg Blocks, User Dashboard Builder, Popup Builder, Form Builder & Animation Builder
- 8.8CVE-2026-110018: aBlocks Privilege Escalation
CVE-2026-110018 - 8.8CVE-2026-57386: aBlocks Privilege Escalation
CVE-2026-57386 - 7.2CVE-2026-40804: aBlocks Stored XSS
CVE-2026-40804 - 6.4CVE-2025-47616: aBlocks <= 1.9.2 Stored Cross-Site Scripting
CVE-2025-47616 - 6.4CVE-2024-13465: aBlocks – WordPress Gutenberg Blocks Stored XSS
CVE-2024-13465
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C