WordPress Core 6.6.0 - 7.1.3 - Authenticated (Contributor+) Clickjacking via Interactivity API Object Bindings
Strategic Overview
- Status
- Patched in 6.6.11
- Affected Core
- WordPress 7.1
- Affected Version
6.6.0 – 7.1.3 · 6 branches- CVSS
- 3.5Low
- Weakness type
- CWE-1021 · Improper Restriction of Rendered UI Layers or Frames
- CVE
CVE pending
At a glance
This record tracks a low-severity Improper Restriction of Rendered UI Layers or Frames vulnerability in the WordPress 7.1 WordPress release line, affecting 6.6.0 – 7.1.3 · 6 branches. It carries a CVSS score of 3.5 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 6.6.11; sites on affected versions should update now. Disclosed October 2026, reported by rekter0.
Vulnerability Overview
WordPress Core is vulnerable to Clickjacking in versions 6.6 through 7.1.3 because Interactivity API bindings allow Contributor-supplied content to replace KSES-approved object attributes and load otherwise restricted same-origin administrative pages. This makes it possible for authenticated attackers, with Contributor-level access and above, to embed administrative interfaces in post content and trick a privileged user into performing an unintended action when interacting with a crafted page.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed.
CWE-1021: Improper Restriction of Rendered UI Layers or Frames
The web application does not restrict or incorrectly restricts frame objects or UI layers that belong to another application or domain.
Remediation
Update to one of the following versions, or a newer patched version: 6.6.11, 6.7.11, 6.8.12, 6.9.11, 7.0.8, 7.1.4
How does WordSec protect against this?
The fix is the thing that ends this: updating to 6.6.11 is the step that ends it.
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WordPress 7.1
- 9.8CVE-2026-63030: WordPress Core 6.9 - 7.0.1 Remote Code Execution
CVE-2026-63030 - 9.8CVE-2024-31211: WordPress Core 6.4.0 - 6.4.1 RCE POP Chain
CVE-2024-31211 - 9.8WordPress Core < 6.0.3 SQL Injection via WP_Date_Query
- 9.8CVE-2021-29476: WordPress Core < 5.5.3 PHP Object Injection Gadget
CVE-2021-29476 - 9.8CVE-2017-16510: WordPress Core SQL Injection
CVE-2017-16510 - 9.8CVE-2017-14723: WordPress Core < 4.8.2 SQL Injection
CVE-2017-14723 - 9.8CVE-2007-6013: WordPress Core 1.5 - 2.3.1 Authorization Bypass
CVE-2007-6013 - 9.8CVE-2007-6318: WordPress Core < 2.3.2 SQL Injection
CVE-2007-6318
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C