WordPress Core 6.4.0 - 7.1.3 - Authenticated (Contributor+) Stored Denial of Service via Malformed Interactivity API Bindings

2026-10-29 00:00
Jon Surrell

Strategic Overview

Status
Patched in 6.4.14
Affected Core
WordPress 7.1
Affected Version
6.4.0 – 7.1.3 · 8 branches
CVSS
3.5Low
Weakness type
CWE-248 · Uncaught Exception
CVE
CVE pending
View all WordPress 7.1 vulnerabilities

At a glance

This record tracks a low-severity Uncaught Exception vulnerability in the WordPress 7.1 WordPress release line, affecting 6.4.0 – 7.1.3 · 8 branches. It carries a CVSS score of 3.5 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 6.4.14; sites on affected versions should update now. Disclosed October 2026, reported by Jon Surrell.

Vulnerability Overview

WordPress Core is vulnerable to a stored client-side Denial of Service in versions 6.4 through 7.1.3 because Interactivity API directive maps and class or style bindings do not validate reserved names and value types before using them. This makes it possible for authenticated attackers, with Contributor-level access and above, to store malformed interactive markup that aborts client-side rendering on affected pages.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed.

CWE-248: Uncaught Exception

An exception is thrown from a function, but it is not caught.

Remediation

Update to one of the following versions, or a newer patched version: 6.4.14, 6.5.14, 6.6.11, 6.7.11, 6.8.12, 6.9.11, 7.0.8, 7.1.4

How does WordSec protect against this?

The fix is the thing that ends this: updating to 6.4.14 is the step that ends it.

  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C