WordPress Core 4.9.6 - 7.1.3 - Authenticated (Editor+) Stored Cross-Site Scripting via Personal Data Erasure Request Email Addresses

2026-10-29 00:00
Anthropic

Strategic Overview

Status
Patched in 4.9.35
Affected Core
WordPress 7.1
Affected Version
4.9.6 – 7.1.3 · 23 branches
CVSS
4.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE pending
View all WordPress 7.1 vulnerabilities

At a glance

This record tracks a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the WordPress 7.1 WordPress release line, affecting 4.9.6 – 7.1.3 · 23 branches. It carries a CVSS score of 4.4 (reachable over the network). Exploitation requires an authenticated account at Editor level or above. The issue is fixed in version 4.9.35; sites on affected versions should update now. Disclosed October 2026, reported by Anthropic.

Vulnerability Overview

WordPress Core is vulnerable to Stored Cross-Site Scripting in versions 4.9.6 through 7.1.3 due to insufficient output escaping of email values stored in personal data requests. This makes it possible for authenticated attackers, with Editor-level access and above, to inject arbitrary web scripts into personal data erasure request records that execute when an administrator visits the personal data erasure requests screen.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Reaching this weakness in WordPress 7.1 4.9.6 – 7.1.3 · 23 branches takes an account at Editor level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For WordPress 7.1 the fix is 4.9.35: builds 4.9.6 – 7.1.3 · 23 branches are affected, anything from 4.9.35 onward is not.

Remediation

Update to one of the following versions, or a newer patched version: 4.9.35, 5.0.31, 5.1.28, 5.2.30, 5.3.27, 5.4.25, 5.5.24, 5.6.23, 5.7.21, 5.8.19, 5.9.20, 6.0.18, 6.1.16, 6.2.15, 6.3.14, 6.4.14, 6.5.14, 6.6.11, 6.7.11, 6.8.12, 6.9.11, 7.0.8, 7.1.4

How does WordSec protect against this?

An attacker needs Editor access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: updating to 4.9.35 is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C