WordPress Core 4.9.0 - 7.1.3 - Unauthenticated Sensitive Information Exposure via Customizer Changesets

Strategic Overview

Status
Patched in 4.9.35
Affected Core
WordPress 7.1
Affected Version
4.9.0 – 7.1.3 · 23 branches
CVSS
5.3Medium
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE pending
View all WordPress 7.1 vulnerabilities

At a glance

This record tracks a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the WordPress 7.1 WordPress release line, affecting 4.9.0 – 7.1.3 · 23 branches. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.9.35; sites on affected versions should update now. Disclosed October 2026, reported by Antonio Lorensius Silaban.

Vulnerability Overview

WordPress Core is vulnerable to Sensitive Information Exposure in versions 4.9 through 7.1.3 because an unauthenticated Customizer preview request without a changeset UUID can adopt the latest unpublished changeset. This makes it possible for unauthenticated attackers to view unpublished Customizer state when an affected changeset exists.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Reaching this weakness in WordPress 7.1 4.9.0 – 7.1.3 · 23 branches takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For WordPress 7.1 the fix is 4.9.35: builds 4.9.0 – 7.1.3 · 23 branches are affected, anything from 4.9.35 onward is not.

Remediation

Update to one of the following versions, or a newer patched version: 4.9.35, 5.0.31, 5.1.28, 5.2.30, 5.3.27, 5.4.25, 5.5.24, 5.6.23, 5.7.21, 5.8.19, 5.9.20, 6.0.18, 6.1.16, 6.2.15, 6.3.14, 6.4.14, 6.5.14, 6.6.11, 6.7.11, 6.8.12, 6.9.11, 7.0.8, 7.1.4

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: updating to 4.9.35 is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C